大三浪 多头粘合副图指标 通达信 源码

N:=65; MA5:=MA(CLOSE,5); MA21:=MA(CLOSE,21); MA65:=MA(CLOSE,N); 多头:=COUNT(MA21>MA65,10)…

N:=65;
MA5:=MA(CLOSE,5);
MA21:=MA(CLOSE,21);
MA65:=MA(CLOSE,N);
多头:=COUNT(MA21>MA65,10)=10;
GX:=MAX(MA5,MAX(MA21,MA65));
DX:=MIN(MA5,MIN(MA21,MA65));
粘合:=ABS(GX/DX-1)*100<=15;
多头粘合:IF(多头 AND 粘合,5,0),COLORFF00FF,LINETHICK2;
{,POINTDOT,NODRAW;}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
庄股:(COUNT(MACD<0,10)=10)*3,COLORFFFF00,LINETHICK1;
{,POINTDOT,NODRAW;}
目标:IF(多头 AND 粘合 AND 庄股,12.8,0),COLORFFFFFF,LINETHICK2;
跟踪:IF(目标,(BARSLAST(CROSS(目标,0))+1)*8,0),COLOR00FF00{,POINTDOT},LINETHICK2;
出击:IF(CROSS(0.1,目标) AND CROSS(MACD,0),16.8,0),COLOR00FFFF,LINETHICK2;
MJSJ:=BARSLAST(出击>0);
涨幅:IF(MJSJ<=120,(C/REF(C,MJSJ)-1)*100,0),COLOR0000FF,LINETHICK1;
{,POINTDOT,NODRAW;}
日涨:IF(MJSJ<=120,涨幅/MJSJ,0),COLORFFFFFF,LINETHICK0;
{,POINTDOT,NODRAW;}
TPX:=MIN(MA65*1.15,MA21*1.13);
突破:IF(CROSS(C,TPX) AND 粘合 AND MA65>REF(MA65,1),20.8,0),COLOR0000F9,LINETHICK2;
{以下设置副图显示方式}
{FILLRGN(涨幅>0,涨幅,0),COLOR222282;}
STICKLINE(涨幅>0,涨幅,0,0,0),COLOR222282;
STICKLINE(多头粘合,0,1,3,0),COLORFF00FF;
STICKLINE(庄股,0,MACD*10,3,0),COLOR99FF00;
DRAWTEXT(出击>0,15.8,'★买'),COLOR00FFFF;
STICKLINE(CROSS(涨幅,20) AND COUNT(CROSS(涨幅,20),MJSJ)=1,-5,10,0,0),COLOR0000FF;

作者: taoguba

为您推荐

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

联系我们

联系我们

       

工作时间:周一至周五,9:00-17:30,节假日休息

关注微信
微信扫一扫关注我们

微信扫一扫关注我们

股票配资
返回顶部