通达信智能选股指标公式

日线锁定:=(PERIOD==5) AND (C>0) AND V>0; 过滤周期:=1; VAR1:=EMA(EMA(CLOSE,9),9); 控盘:=(VAR1-R…

日线锁定:=(PERIOD==5) AND (C>0) AND V>0;
过滤周期:=1;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
资金:=EMA(EMA(CLOSE,8),8);
资金抬轿:=(资金-REF(资金,1))/REF(资金,1)*1000;
有庄控盘:=资金抬轿>0; 无庄控盘:=资金抬轿<=0;
买线:=EMA(C,3);
卖线:=EMA(SLOPE(C,22)*20+C,54);
BU1:=CROSS(买线,卖线);
SEL1:=CROSS(卖线,买线);
BU2:=IFF(BU1 AND 有庄控盘,1,IFF(COUNT(BU1 AND 无庄控盘,BARSLAST(SEL1)+1)==1 AND CROSS(资金抬轿,0),1,0));
BU:=BU2 AND COUNT(BU2,BARSLAST(SEL1)+1)==1;
SEL:=SEL1 AND COUNT(SEL1,BARSLAST(BU)+1)==1;
BUNEW:=BU;
止损条件:=CLOSE/REF(OPEN,BARSLAST(BU))<(1-7/100) AND COUNT(BU,BARSLAST(BU)+1)==1 AND COUNT(SEL,BARSLAST(BU)+1)==0;
SELNEW:=IFF(止损条件 AND COUNT(止损条件,BARSLAST(BU)+1)==1,1,IFF(SEL AND COUNT(止损条件,BARSLAST(BU)+1)==0,1,0));
重新买入:=COUNT(止损条件,BARSLAST(BUNEW)+1)>=1 AND CROSS(C,0.965*REF(O,BARSLAST(BUNEW)));
不在同一天1:=((重新买入 AND SELNEW)==0); BUNEW2:=((BUNEW AND COUNT(SELNEW,过滤周期)==0) OR 重新买入) AND 不在同一天1;
二次止损:=(CLOSE/REF(OPEN,BARSLAST(重新买入))<(1-7/100) AND COUNT(重新买入,BARSLAST(重新买入)+1)==1 AND COUNT(SEL,BARSLAST(重
新买入)+1)==0);
重新卖出:=(SEL AND COUNT(重新买入,BARSLAST(BUNEW2)+1)==1) OR (二次止损 AND SUM(二次止损,0)==1);
不在同一天2:=((重新卖出 AND BUNEW2)==0);
SELNEW2:=((SELNEW AND COUNT(SELNEW,BARSLAST(BUNEW2)+1)==1) OR 重新卖出) AND 不在同一天2;
BUNEW3:=BUNEW2 AND COUNT(BUNEW2,BARSLAST(SELNEW2)+1)==1;
SELNEW3:=SELNEW2 AND COUNT(SELNEW2,BARSLAST(BUNEW3)+1)==1;
D:=BARSLAST(BUNEW3)+1>=1 AND COUNT(SELNEW3,BARSLAST(BUNEW3)+1)==0;
K:=BARSLAST(SELNEW3)+1>=1 AND COUNT(BUNEW3,BARSLAST(SELNEW3)+1)==0;
修正部分定位:=IFF(COUNT(SELNEW3,BARSCOUNT(C))==0 AND COUNT(BUNEW3,BARSCOUNT(C))==0,1,0);
上市修正B:=修正部分定位 AND CROSS(控盘,0);
上市修正S:=修正部分定位 AND CROSS(0,控盘) AND COUNT(上市修正B,BARSLAST(C>0))>=1;
上市D:=COUNT(上市修正B,BARSLAST(上市修正B)+1)==1 AND COUNT(上市修正S,BARSLAST(上市修正B)+1)==0 AND COUNT (SELNEW3,BARSCOUNT
(C))==0;
上市K:=COUNT(上市修正S,BARSLAST(上市修正S)+1)==1 AND COUNT(上市修正B,BARSLAST(上市修正S)+1)==0 AND COUNT
(BUNEW3,BARSCOUNT(C))==0;
SSXZBZS:=COUNT(上市修正B,BARSCOUNT(C));
SSXZSZS:=COUNT(上市修正S,BARSCOUNT(C));
QB:=IFF(修正部分定位,上市修正B,BUNEW3);
QS:=IFF(修正部分定位,上市修正S AND (SSXZBZS==SSXZSZS AND SSXZBZS>=0 AND COUNT(SELNEW3,BARSCOUNT(C))==1 AND COUNT
(BUNEW3,BARSCOUNT(C))==0)==0, SELNEW3 AND (SSXZBZS==SSXZSZS AND SSXZBZS>=0 AND COUNT(SELNEW3,BARSCOUNT(C))==1 AND COUNT
(BUNEW3,BARSCOUNT(C))==0)==0);
K补:=(COUNT(上市修正B,BARSLAST(C>0))==0 AND COUNT(QB,BARSLAST(C>0))==0)==0;
XG:QB AND 日线锁定;

作者: taoguba

为您推荐

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

联系我们

联系我们

       

工作时间:周一至周五,9:00-17:30,节假日休息

关注微信
微信扫一扫关注我们

微信扫一扫关注我们

股票配资
返回顶部